nullishamy d61882ad9f
feat: build with deno; improve theme coverage (#8)
* feat: build with deno; improve theme coverage

* chore: use standard description format

Co-authored-by: uncenter <47499684+uncenter@users.noreply.github.com>

* style: refactor

* fix: generate seeded uuid for `id`

* feat: theme active button

* fix: use proper encoder

* chore: refactor; add images

* doc: readme usage

* feat: more accented colours

* chore: optimise nix deps

Co-authored-by: Hamothy <58985301+sgoudham@users.noreply.github.com>

* doc: remove hammy troll comments

Co-authored-by: Hamothy <58985301+sgoudham@users.noreply.github.com>

---------

Co-authored-by: uncenter <47499684+uncenter@users.noreply.github.com>
Co-authored-by: Hamothy <58985301+sgoudham@users.noreply.github.com>
2024-02-25 16:56:32 +00:00

18 lines
429 B
Nix

{
inputs = {
nixpkgs.url = "github:nixos/nixpkgs/nixos-23.11";
flake-utils.url = "github:numtide/flake-utils";
};
description = "Development shell flake";
outputs = { self, nixpkgs, flake-utils }: flake-utils.lib.eachDefaultSystem (system: {
devShell = let
pkgs = nixpkgs.legacyPackages.${system};
in
pkgs.mkShell {
packages = with pkgs; [
deno
];
};
});
}